Kajona V6.2 released

06/07/2017

Kajona 6.2 shifts the focus to PHP 7


With the release 6.2 the open source CMS jumps from 5.1 to 6.2. This is based on the streamlined focus on PHP 7. In consequence, Kajona 6.2 will no longer run using PHP 5, the minimal requirement is PHP 7.

Attention: Kajona 6.2 requires at least PHP 7.0!

Besides this change regarding the technical requirements, various areas of the system have been updated.

The demo template was updated to the latest version of Bootstrap, Bootstrap 4 alpha 6. Due to the fundamental changes introduces in the latest alpha, layouts based on BS4 require extra testing towards the compatibility.

The upload functionality in module mediamanager was modernized, pasting images using the clipboard by using copy and paste is now supported for modern browsers (currently only supported by Chrome).
In addition, the backends shows actions, filters and buttons on various pages in a central toolbar, reducing the visual clutter on the backend.

Kajonas internal user-management was redesigned to make use of shorter ids for groups. This affects installations with a large number of groups (> 1500), resulting in a performance boost. The merge of the system- and permission-table speeds up the execution of long-running queries, too.

By combining the processes during the creation or import of database backups (piping of dump/restore and zip binaries) the disk-space used during those processes is reduced significantly.


The Kajona default package includes all relevant base-modules and can be downloaded right here:
>>> Download Kajona V6
Our quick install guide describes all relevant steps to install Kajona successfully in just a few minutes.
Upgrading an existing installation just got easier with our new upgrade-script. Details can be found in the upgrade guide.

Why not giving the new version a try by throwing a glance at our running demo-system?
Filed under: TOP-News en Kajona News en
No comments made till now
Fork me on GitHub